HPsocket

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 122|回复: 5

[易语言] hpsocket端口转发

[复制链接]
发表于 2022-7-6 09:58:53 | 显示全部楼层 |阅读模式
易语言hpsocket端口转发,此源码是转载别人的收集整理一下一起玩玩吧,以后会收集一些网络上相关HP 的代码贴在本网,缺少模块的话可以在本论坛下载相关的模块即可 DLL可以用中文模块的命令输出一定要跟模块版本匹配才可以
9 |; m+ h. P: f/ b6 n; \# {$ @) B- u! N9 R$ [" \/ W  v
[AppleScript] 纯文本查看 复制代码
.版本 2
.支持库 iext

.子程序 _启动转发_被选择
.局部变量 本地端口, 整数型
.局部变量 目标ip, 文本型
.局部变量 目标端口, 整数型
.局部变量 l_Ret, 整数型
.局部变量 名字, 文本型

.如果真 (n_ForwardList.现行选中项 ≠ -1)
    .如果真 (n_ForwardList.取表项数值 (n_ForwardList.现行选中项) ≠ 0)
        返回 ()
    .如果真结束
    本地端口 = 到整数 (n_ForwardList.取标题 (n_ForwardList.现行选中项, 3))
    目标ip = n_ForwardList.取标题 (n_ForwardList.现行选中项, 1)
    名字 = n_ForwardList.取标题 (n_ForwardList.现行选中项, 0)
    目标端口 = 到整数 (n_ForwardList.取标题 (n_ForwardList.现行选中项, 2))
    创建服务 (名字, 到整数 (本地端口), 到整数 (目标端口), 目标ip)
    .如果真 (l_Ret = 0)
        ' 信息框 (“转发启动失败”, #警告图标, , )
        ' 返回 ()
    .如果真结束
    n_ForwardList.置图片 (n_ForwardList.现行选中项, 0, 1)
    n_ForwardList.置表项数值 (n_ForwardList.现行选中项, l_Ret)
/ T7 w2 H% _1 F& g: c8 r
+ Z' E) t: u& u$ c
游客,如果您要查看本帖隐藏内容请回复
' j4 y' s2 X. H/ S* h+ f1 A
发表于 2022-7-9 10:37:36 | 显示全部楼层
非常感谢楼主分享
回复

使用道具 举报

发表于 2022-8-25 21:38:10 | 显示全部楼层
学习学习。。
回复

使用道具 举报

发表于 2022-9-19 11:08:47 | 显示全部楼层
xuex学习一下
回复

使用道具 举报

发表于 2022-10-21 18:35:20 | 显示全部楼层
这个看看可以!
回复

使用道具 举报

发表于 2022-10-23 11:01:57 | 显示全部楼层
这个好,学习下
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|HPsocket-国产高性能通讯框架 ( 豫ICP备19038015号-1 )|网站地图 *//

GMT+8, 2022-11-26 17:53 , Processed in 0.208958 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表