HPsocket

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 92|回复: 3

[易语言] hp-socket的PULL组件使用例子

[复制链接]
发表于 2022-7-6 10:13:55 | 显示全部楼层 |阅读模式
* Z3 l1 Y6 @; \! g$ U, _
HP-Socket的PULL组件使用例子 PULL组件使用的人很少因为他需要自己组包,但是还是有人问这个东西所以就发出来了,源码中需要的模块 DLL 证书啥的 可以去 论坛下载中文例子 里面包含了所有的东西复制过去就行了* ]; \% n) @8 O  n6 q2 t3 g
; j8 ~2 ]5 g: m% {) V% W
hpsocket中文模块使用例子5.8.81 g9 ~2 e- Z! a, c- r+ Q8 T& O$ ]
https://www.hpsocket.cn/forum.ph ... d=109&fromuid=1
$ F( M7 O6 u) l# x( D8 V4 h( p( H(出处: HPsocket)( d" ?! p1 `8 v! u+ [* l

/ Q4 a" z4 {9 K9 h. y2 X* h
[AppleScript] 纯文本查看 复制代码
.版本 2

.子程序 _按钮_启动_被单击
.局部变量 绑定地址, 文本型
.局部变量 端口, 整数型

绑定地址 = 编辑框_服务器IP.内容
端口 = 7777
全_服务器句柄 = PULL服务端.创建 (选择框_SSL.选中)
.如果真 (选择框_SSL.选中 = 真)
    PULL服务端.清理SSL (全_服务器句柄)
    PULL服务端.初始化SSL (全_服务器句柄, #SSL_SM_SERVER, “ssl-cert\server.cer”, “ssl-cert\server.key”, “123456”, “ssl-cert\ca.crt”, )
.如果真结束
PULL服务端.事件_监听 (&监听事件)
PULL服务端.事件_客户进入 (&客户进入事件)
PULL服务端.事件_发送 (&发送事件)
PULL服务端.事件_接收 (&接收事件)
PULL服务端.事件_断开 (&客户端断开事件)
PULL服务端.事件_关闭 (&关闭事件)
PULL服务端.事件_握手 (&握手事件)
PULL服务端.置最大连接数 (全_服务器句柄, 2000)
PULL服务端.置发送策略 (全_服务器句柄, 1)  ' 0=打包模式  1=安全模式  2=直接模式
PULL服务端.置心跳包间隔 (全_服务器句柄, 6000)
PULL服务端.置异常心跳包间隔 (全_服务器句柄, 7000)
动态设置组件状态 (#ST_STARTING)
.如果 (PULL服务端.启动 (全_服务器句柄, 绑定地址, 端口))
    输出日志 (“服务器启动成功监听地址为;” + 绑定地址 + “端口为;” + 到文本 (端口))
    PULL服务端.置工作线程数量 (全_服务器句柄, 1000)
    动态设置组件状态 (#ST_STARTED)
.否则
    输出日志 (“服务器启动失败错误描述为;” + PULL服务端.取错误描述 (全_服务器句柄) + “错误代码为;” + 到文本 (PULL服务端.取错误代码 (全_服务器句柄)) + “)”)
    动态设置组件状态 (#ST_STOPED)

2 r6 \. c5 h7 o# _
游客,如果您要查看本帖隐藏内容请回复
# W  O4 K8 \+ C) z; l( C
" u$ l# Q6 P" H& M. @
发表于 2022-8-25 21:38:44 | 显示全部楼层
收藏学习下。。
回复

使用道具 举报

发表于 2022-9-29 20:48:05 | 显示全部楼层
hp-socket的PULL组件使用例子
回复

使用道具 举报

发表于 2022-10-8 17:11:59 | 显示全部楼层
RE: hp-socket的PULL组件使用例子 [修改]: n8 ~) s1 Y" v- |8 ~% I' D0 I
高级模式
( }& [2 @+ \, W  P5 ~: ^, g5 W
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|HPsocket-国产高性能通讯框架 ( 豫ICP备19038015号-1 )|网站地图 *//

GMT+8, 2022-12-1 02:05 , Processed in 0.167714 second(s), 26 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表