找回密码
 立即注册

QQ登录

只需一步,快速开始

搜索
热搜: 中文模块 Demo
查看: 264|回复: 0

[易语言] 抓取数据整数型

[复制链接]
发表于 2022-9-30 13:48:28 | 显示全部楼层 |阅读模式
6 K2 l% }8 ]" L( P2 v/ a- n
由于5.8.8之后的版本更新 更新了抓取数据这个命令导致之前的一些DEMO出现简单的用法错误 在此更新 抓取数据整数型
4 K& W+ j2 @& g  ?9 O$ l
[AppleScript] 纯文本查看 复制代码
.版本 2
.支持库 spec

.子程序 数据接收事件, 整数型
.参数 客户端句柄, 整数型
.参数 连接ID, 整数型
.参数 参_数据长度, 整数型
.局部变量 局_数据指针, 整数型
.局部变量 局_TLV, TLV解包

局_数据指针 = 申请内存 (参_数据长度, )
PULL客户端.抓取数据 (全_客户端句柄, 局_数据指针, 参_数据长度)
' ----------------------------------------------
局_TLV.Type = 取字节集数据 (指针到字节集 (局_数据指针, 4), #整数型, )
局_TLV.Lenggth = 取字节集数据 (指针到字节集 (局_数据指针 + 4, 4), #整数型, )
局_TLV.Value = 指针到字节集 (局_数据指针 + 8, 局_TLV.Lenggth)
' ------------------------------------------------
输出日志 (“《接收》;” + 到文本 (局_TLV.Value))
释放内存 (局_数据指针)
返回 (#HR_OK)
, ]6 V4 V0 i* U' s- z& d
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

关闭

站长推荐上一条 /4 下一条

QQ|Archiver|手机版|小黑屋| HPsocket-国产高性能通讯框架 ( 豫ICP备19038015号-1 )|网站地图

GMT+8, 2024-4-25 06:34 Powered by Discuz! X3.5 *//

快速回复 返回顶部 返回列表