HPsocket

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 25|回复: 0

[易语言] 抓取数据整数型

[复制链接]
发表于 2022-9-30 13:48:28 | 显示全部楼层 |阅读模式
" p. V7 r* Y1 r! p& [8 v3 v! r
由于5.8.8之后的版本更新 更新了抓取数据这个命令导致之前的一些DEMO出现简单的用法错误 在此更新 抓取数据整数型; D$ J6 I9 S2 A8 u7 z+ \
[AppleScript] 纯文本查看 复制代码
.版本 2
.支持库 spec

.子程序 数据接收事件, 整数型
.参数 客户端句柄, 整数型
.参数 连接ID, 整数型
.参数 参_数据长度, 整数型
.局部变量 局_数据指针, 整数型
.局部变量 局_TLV, TLV解包

局_数据指针 = 申请内存 (参_数据长度, )
PULL客户端.抓取数据 (全_客户端句柄, 局_数据指针, 参_数据长度)
' ----------------------------------------------
局_TLV.Type = 取字节集数据 (指针到字节集 (局_数据指针, 4), #整数型, )
局_TLV.Lenggth = 取字节集数据 (指针到字节集 (局_数据指针 + 4, 4), #整数型, )
局_TLV.Value = 指针到字节集 (局_数据指针 + 8, 局_TLV.Lenggth)
' ------------------------------------------------
输出日志 (“《接收》;” + 到文本 (局_TLV.Value))
释放内存 (局_数据指针)
返回 (#HR_OK)
0 `4 Z( f( |4 a' D
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|小黑屋|HPsocket-国产高性能通讯框架 ( 豫ICP备19038015号-1 )|网站地图 *//

GMT+8, 2022-12-1 01:40 , Processed in 0.162613 second(s), 23 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表